Content Delivery Network Issues
Resolved·Degraded performance

The issue has been fixed.

Wed, Nov 19, 2025, 09:07 AM
(3 weeks ago)
·
Affected components
App
Booking
Updates

Resolved

The issue has been fixed.

Wed, Nov 19, 2025, 09:07 AM

Resolved

The issue has been fixed.

Tue, Nov 18, 2025, 05:06 PM(16 hours earlier)

Identified

We are currently experiencing intermittent issues caused by a global Cloudflare outage. Since Cloudflare is our CDN provider, parts of our platform may show degraded performance or transient errors.

Current Status:
Some errors were observed on the API Gateway earlier, but services are mostly stable at the moment. We are monitoring the situation closely and will update as Cloudflare progresses with their mitigation.

Tue, Nov 18, 2025, 12:39 PM(4 hours earlier)